:: PlayerAdvance.org ::  

Précédent   :: PlayerAdvance.org :: > :: Forums Hébergés :: > OldSchool Library > Aide au développement

Aide au développement Aide sur l'utilisation d'OSLib

Publicité

Réponse
 
Outils de la discussion Modes d'affichage
Vieux 18/11/2009, 11h57   #1
G43L
Newbie
 
Date d'inscription: 18/11/2009
Messages: 2
Par défaut Jouer un mp3 avec la version 2.10

Bonjour à tous,

J'ai décidé d'utiliser OSLib 2.10 et jusqu'à présent tout va bien. Mais hier, quand j'ai voulu ajouter de la musique au format mp3, le premier problème sérieux s'est posé. Mon programme plante complètement...

J'ai déjà posté ici: http://forums.ps2dev.org/viewtopic.php?p=85963#85963
pour les détails techniques.

Si quelqu'un a rencontré/résolu ce problème, eh bien, qu'il se manifeste


Merci d'avance,
G43L

Dernière modification par Dr.Vince ; 19/11/2009 à 01h18.
G43L est déconnecté   Réponse avec citation

Publicité

Vieux 18/11/2009, 15h50   #2
Dr.Vince
Administrateur
 
Date d'inscription: 10/11/2005
Messages: 4 962
Voir les codes amis Nintendo DS Voir les codes amis Wii
Par défaut

utilise la méthode oslLoadSoundFileMP3, c'est ce que je fais et j'ai aucun soucis

en entête de mon main j'ai ça:

Code:
PSP_MODULE_INFO("Blob Runner", 0, 1, 0);
PSP_MAIN_THREAD_ATTR(THREAD_ATTR_USER | THREAD_ATTR_VFPU);
PSP_HEAP_SIZE_MAX();
par contre j'ai un doute là, t'es sûr que la 2.1 gère le MP3, faut pas utiliser la 2.1 MOD de Sakya ?
__________________
Projets Abandonnés: [Arcomage Advance] [Puzznic] [PA Card Games] [Blob Runner]
Projet en cours: [Ne plus abandonner de projet...]
Dr.Vince est déconnecté   Réponse avec citation
Vieux 18/11/2009, 22h49   #3
G43L
Newbie
 
Date d'inscription: 18/11/2009
Messages: 2
Par défaut

Citation:
Envoyé par Dr.Vince Voir le message
utilise la méthode oslLoadSoundFileMP3, c'est ce que je fais et j'ai aucun soucis

en entête de mon main j'ai ça:

Code:
PSP_MODULE_INFO("Blob Runner", 0, 1, 0);
PSP_MAIN_THREAD_ATTR(THREAD_ATTR_USER | THREAD_ATTR_VFPU);
PSP_HEAP_SIZE_MAX();
par contre j'ai un doute là, t'es sûr que la 2.1 gère le MP3, faut pas utiliser la 2.1 MOD de Sakya ?
oslLoadSoundFileMP3() et oslInitAudioME(OSL_FMT_MP3) ont réglé mon problème. Merci beaucoup!

G43L
G43L est déconnecté   Réponse avec citation
Réponse

Liens sociaux

Publicité



Utilisateurs regardant la discussion actuelle : 1 (0 membre(s) et 1 invité(s))
 
Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non
Navigation rapide

Discussions similaires
Discussion Auteur Forum Réponses Dernier message
NDS PuzzleManiak Alx Projets 275 06/04/2010 20h10
NDS MoonShell M@cZér0 Articles et Tutos 511 26/12/2009 16h46
Wi-Fi avec Freebox HD impossible ? ShiRo [NDS] Divers 5 20/02/2007 15h33
[Pré-Projet GBA] Insane Island Japi [DEV] Pré-Projets 46 14/07/2006 22h23
NDS comment jouer aux jeux DS avec M3 ? Lefangoldensun Linkers M3/R4 11 16/02/2006 16h54


Fuseau horaire GMT +2. Il est actuellement 09h44.


Édité par : vBulletin® version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd. Tous droits réservés.
Version française #16 par l'association vBulletin francophone
Design par Ass-Itch, DJP et Dr.Vince