:: PlayerAdvance.org ::  

Précédent   :: PlayerAdvance.org :: > :: Développement Amateur :: > Tutoriels

Publicité

Réponse
 
Outils de la discussion Modes d'affichage
Vieux 21/02/2008, 14h22   #26
JoJoS
Membre confirmé
 
Date d'inscription: 17/11/2006
Messages: 50
Par défaut

Haaa, ça fait plaisir de voir que ce tuto sert à quelqu'un !!!
Et moi qui pensai qu'il me servirait juste de pense-bête...

J'ai pas vraiment compris t'as dernière phrase, tu as réussi à compiler ou non ?
JoJoS est déconnecté   Réponse avec citation

Publicité

Vieux 21/02/2008, 15h08   #27
oks2024
 
Messages: n/a
Par défaut

Je vais mieux expliquer .

J'ai commencé par installer la dernière version de devkitARM, c'est a dire la 21.
J'ai ensuite insallé la derniere version stable de PAlib, rajouté ton template a xCode, et tenté de compiler le fichier par defaut. Et la il m'a sorti une erreur de compilation venant d'un fichier de la PAlib.
Aprés quelques recherches, j'a trouvé une personne ayant eu le même problème http://gueux-forum.net/index.php?showtopic=171721 .
J'ai donc essayé avec devkitARM 20 et maintenant je n'ai plus de problème .
  Réponse avec citation
Vieux 27/02/2008, 23h34   #28
lyonnel4
Membre
 
Date d'inscription: 20/02/2006
Messages: 18
Par défaut

salut,
merci pour ce tuto.
il va me faciliter les choses.
jusqu'à present xcode ne me servait que d'editeur de fichier .c ou .h et je compilais via le terminal.
maintenant, je vais pouvoir faire les choses plus simplement.

petite question: comment faire pour faire un projet xcode à partir des fichiers de mes precedents projets ?
lyonnel4 est déconnecté   Réponse avec citation
Vieux 01/03/2008, 11h36   #29
JoJoS
Membre confirmé
 
Date d'inscription: 17/11/2006
Messages: 50
Par défaut

Salut !!!
Haa je suis ravi de voir des développeur sous osx !!

Pour réutiliser tes sources, le mieux est de faire un nouveau projet DS à partir d'Xcode, puis dans le Finder tu copies toutes tes sources dans le répertoires "sources" de ton projet.
Ensuite, tu retournes dans Xcode, et tu clic droit (control-clic) sur le répertoire source. Là tu choisis "Add Existing Files...", puis tu sélectionnes tous tes fichier sources.

Par contre je crois qu'il y a un problème avec le répertoire gfx...
Lorsqu'on met les sources des images, il se peut qu'à la compilation ça râle.

Dans ce cas, il faut, dans le Finder, déplacer le répertoire "gfx" dans le répertoire "sources".
Xcode va colorer le texte en rouge pour préciser qu'il ne trouve plus ce répertoire.
Pas de problème, un petit tour dans l'inspecteur (pomme-i) puis on indique son nouveau chemin d'accès avec le bouton "choose".

Je réglerai ce petit problème la prochaine fois...

Citation:
J'ai commencé par installer la dernière version de devkitARM, c'est a dire la 21.
J'ai ensuite insallé la derniere version stable de PAlib, rajouté ton template a xCode, et tenté de compiler le fichier par defaut. Et la il m'a sorti une erreur de compilation venant d'un fichier de la PAlib.
Aprés quelques recherches, j'a trouvé une personne ayant eu le même problème http://gueux-forum.net/index.php?showtopic=171721 .
J'ai donc essayé avec devkitARM 20 et maintenant je n'ai plus de problème .
Je ne trouve ça pas terrible de la part des développeurs de devkitARM de ne pas assurer une rétro compatibilité avec ses versions précédentes... Ca oblige les dév des librairies à ré-écrire certaine partie de leur code.
Enfin bon, ce doit être pour économie de "place" pour la rom...

En tout cas, ravis que cela fonctionne bien à présent !!

Dernière modification par JoJoS ; 01/03/2008 à 11h45.
JoJoS est déconnecté   Réponse avec citation
Vieux 29/03/2008, 14h07   #30
Cortes48
Modérateur
 
Date d'inscription: 28/02/2007
Localisation: Grenoble
Messages: 576
Par défaut

Bonjour

J ai tout instaler mais quand je compile j ai une erreur

C
Code:
ommand /usr/bin/make failed with exit code 2
Que dois je faire ?
Cortes48 est déconnecté   Réponse avec citation
Vieux 10/04/2008, 21h06   #31
JoJoS
Membre confirmé
 
Date d'inscription: 17/11/2006
Messages: 50
Par défaut

Citation:
Envoyé par Cortes48 Voir le message
Bonjour

J ai tout instaler mais quand je compile j ai une erreur

C
Code:
ommand /usr/bin/make failed with exit code 2
Que dois je faire ?
Arf, désolé pour ce retard...
Je ne passe plus très souvent par là.

Essai de placer le repertoire gfx dans le dossier source directement.
Sinon, là comme ça, je ne vois pas trop quel est le problème...

T'es parti d'un template neuf ou d'un projet déjà avancé ?
JoJoS est déconnecté   Réponse avec citation
Vieux 14/04/2008, 13h10   #32
lisapple
 
Messages: n/a
Par défaut

Bonjour tout le monde! je suis ravis de voir que quelqu'un s'intéresse au mac users pour ce dvp! par contre le lien vers le template Xcode et mort! Si c'est possible d'avoir un nouveau lien... merci d'avance
  Réponse avec citation
Vieux 02/05/2008, 11h28   #33
JoJoS
Membre confirmé
 
Date d'inscription: 17/11/2006
Messages: 50
Par défaut

Arf, désolé !!

Je n'ai plus beaucoup de temps à consacrer au dév ds en ce moment ...

Pour le template c'est bizarre que le lien ai sauté ...
Je vais voir ce qu'il se passe.

[EDIT]
Après vérification, le lien n'est pas mort ...
Re-tente le téléchargement pour voir.
JoJoS est déconnecté   Réponse avec citation
Vieux 15/05/2008, 16h49   #34
lyonnel4
Membre
 
Date d'inscription: 20/02/2006
Messages: 18
Par défaut

Salut,
je tiens à te remercier (avec beaucoup de retard , désolé) pour ta réponse très complète à ma petite question.
lyonnel4 est déconnecté   Réponse avec citation
Vieux 28/05/2008, 14h22   #35
JoJoS
Membre confirmé
 
Date d'inscription: 17/11/2006
Messages: 50
Par défaut

Et bien "de rien" un peu en retard également...
JoJoS est déconnecté   Réponse avec citation
Vieux 28/12/2008, 17h16   #36
gogohan
Newbie
 
Date d'inscription: 28/12/2008
Messages: 3
Par défaut Problème compilation Xcode

Bonjour

Je me permets de remonter ce topic car j'ai un petit problème de linkage et de headers...
J'ai suivi le tutoriel conformément à ce qui est décrit et j'ai donc mon template Nintendo DS qui me permet de créer un nouveau projet

Malheureusement, je ne peux pas compiler

Les erreurs:
Error: PA9.h: No such file or directory
Warning: Implicit declaration of function 'PA_Init'/'PA_InitVBL'/'PA_WaitForVBL()'

Quand je passe par le makefile, j'ai les même erreurs.
Je code depuis 1 an en C/C++/Obj-C maintenant pour Mac OS X, et j'ai fait 2 ans sous Windows de C/C++, donc je sais à peu prêt me servir de gcc et de Xcode

Merci de votre aide
gogohan est déconnecté   Réponse avec citation
Vieux 28/12/2008, 17h25   #37
Dr.Vince
Administrateur
 
Date d'inscription: 10/11/2005
Messages: 4 963
Voir les codes amis Nintendo DS Voir les codes amis Wii
Par défaut

bah il trouve pas PAlib, as-tu fais exactement ce qu'il y a d'écrit dans le tuto ?

Citation:
Maintenant, décompresser l'archive de la PAlib dans le répertoire /opt/local/devkitPRO/. Noter que l'archive comprend un dossier PAlib, vous devez donc glisser le contenu de ce dossier.
__________________
Projets Abandonnés: [Arcomage Advance] [Puzznic] [PA Card Games] [Blob Runner]
Projet en cours: [Ne plus abandonner de projet...]
Dr.Vince est déconnecté   Réponse avec citation
Vieux 28/12/2008, 17h47   #38
gogohan
Newbie
 
Date d'inscription: 28/12/2008
Messages: 3
Par défaut

J'ai mis le dossier PAlib de l'archive nommée PAlib_080823_Archive dans ce chemin...

Des screens à partir du finder:

http://www.boostupload.com/img.php?i...128_Image2.png

http://www.boostupload.com/img.php?i...194_Image3.png

EDIT: J'ai trouvé le pb, la version de PAlib est différente de celle que l'auteur du tutoriel... Elle a été mise à jour, et pas le makefile (je corrige mon makefile pour voir, par exemple le dossier $(DEVKITPRO)/PAlib/include/nds devient $(DEVKITPRO)/PAlib/lib/include/nds --'

J'ai pris une version de 2007 et j'ai un nouveau bug : REG_EXEMEMCNT n'est pas déclaré --'

Dernière modification par gogohan ; 28/12/2008 à 18h17.
gogohan est déconnecté   Réponse avec citation
Vieux 28/12/2008, 18h56   #39
Dr.Vince
Administrateur
 
Date d'inscription: 10/11/2005
Messages: 4 963
Voir les codes amis Nintendo DS Voir les codes amis Wii
Par défaut

prend une ancienne version, ça t'évitera bien des soucis je pense
__________________
Projets Abandonnés: [Arcomage Advance] [Puzznic] [PA Card Games] [Blob Runner]
Projet en cours: [Ne plus abandonner de projet...]
Dr.Vince est déconnecté   Réponse avec citation
Vieux 28/12/2008, 19h02   #40
gogohan
Newbie
 
Date d'inscription: 28/12/2008
Messages: 3
Par défaut

Quelle version me conseilles tu ? :-°
gogohan est déconnecté   Réponse avec citation
Vieux 28/12/2008, 19h11   #41
Dr.Vince
Administrateur
 
Date d'inscription: 10/11/2005
Messages: 4 963
Voir les codes amis Nintendo DS Voir les codes amis Wii
Par défaut

bah sois tu prend la nouvelle version de PAlib avec libnds et tu modifie ce qui pose problème soit tu prend les versions juste avant

je peux pas t'aider plus car je dev pas sur NDS
__________________
Projets Abandonnés: [Arcomage Advance] [Puzznic] [PA Card Games] [Blob Runner]
Projet en cours: [Ne plus abandonner de projet...]
Dr.Vince est déconnecté   Réponse avec citation
Vieux 28/12/2008, 23h05   #42
CarbonACat
Membre confirmé
 
Date d'inscription: 16/11/2008
Localisation: Dreux
Messages: 150
Par défaut

Attention a la dernière version de devkitarm /libndsqui changent pas mal de choses!

Je crois que c'etait la r21 qui était conseillée pour devkitpro, avec la PALib actuelle
__________________
Meow!
CarbonACat est déconnecté   Réponse avec citation
Vieux 01/02/2009, 20h11   #43
Shifty
Membre confirmé
 
Date d'inscription: 05/09/2007
Messages: 54
Par défaut

Hello tout le monde !

Merci à JoJos pour ce tuto.

Toutefois j'ai un petit problème, le marteau "build-and-go" est grisé impossible de cliquer dessus.

Quelqu'un a t-il une idée de solution ?

Merci
Shifty est déconnecté   Réponse avec citation
Vieux 01/09/2009, 22h36   #44
lulutiz
Membre
 
Date d'inscription: 17/01/2007
Messages: 36
Par défaut

Bonjour,
Merci pour ce petit tuto, que je t'avoue n'ai que survolé car j'en ai suivi un autre sur le wiki palib. Ils se rejoignent, mais le problème reste le même.
J'ai un PowerPc et d'après ce que j'ai vu, la r21 est la dernière qui soit compatible avec les PPC.
Or, cette release est introuvable, la moins récente que je trouve est la 22.
Ai-je tord?
Autre question: la compatibilité des dernières mises à jour Palib va-t-elle être problématique si je reste sur la 21?

merci

EDIT: Je m' auto-réponds, mais on sait jamais ça peut servir à quelqu'un d'autre, j'ai trouvé:

Windows: http://mirror.optus.net/sourceforge/..._r21-win32.exe
OSX PPC: http://mirror.optus.net/sourceforge/...21-osx-ppc.bz2
OSX Intel: http://mirror.optus.net/sourceforge/...-osx-intel.bz2
Linux: http://mirror.optus.net/sourceforge/...-linux.tar.bz2

Tout fonctionne nickel merci le tuto!

Dernière modification par lulutiz ; 09/09/2009 à 19h43.
lulutiz est déconnecté   Réponse avec citation
Vieux 11/11/2009, 13h45   #45
lambo
Newbie
 
Date d'inscription: 11/11/2009
Messages: 1
Par défaut

Super ton tuto JoJoS, même maintenant il sert à des gens
C'est exactement ce que je cherchait, merci !
lambo est déconnecté   Réponse avec citation
Réponse

Liens sociaux

Publicité



Utilisateurs regardant la discussion actuelle : 1 (0 membre(s) et 1 invité(s))
 
Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non
Navigation rapide


Fuseau horaire GMT +2. Il est actuellement 08h14.


Édité par : vBulletin® version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd. Tous droits réservés.
Version française #16 par l'association vBulletin francophone
Design par Ass-Itch, DJP et Dr.Vince